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Getting Started with Layers

Layers are the most fundamental feature in Photoshop. They allow us to non-
destructively construct a document, while giving us the most versatile way of 
working. Layers can be used for something as simple as creating a photo grid or 
as complicated as a complex composite. 

If we construct a document without using layers (where all the content would be 
placed on a single, “background” layer), we will not be able to make changes to 
the individual parts. In the video example, we have a document with an image, a 
white text box and text inside of the box. We first created this document without 
using layers and as a result, we could not go back and change the text, the color 
and size of the text, the position and opacity of the box, etc. It’s all baked in and we 
can not make changes to one piece without affecting the document as a whole. 

In this document, everything is placed on the same layer. 
This prevents us from making changes to the individual 
components.
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Let’s reconstruct this document a second time, using layers so that we have more 
versatility. 

The Layers Panel The Layers panel is located, by default, on the right side of 
the Photoshop interface. The panel will show all of the layers in your document. 
When you open an image for the first time, you will only have one layer, titled the 
Background Layer. 

Creating a New Layer To create a new, empty 
layer, click on the New Layer icon at the bot-
tom of the Layers panel. After creating a new, 
empty layer, the layer’s thumbnail will appear 
in the Layers panel and there will be a check-
erboard pattern on it, indicating that the layer 
is completely empty. (Any time you see this 
checkerboard pattern, it represents empty 
space on which there are no pixels.) You can 
change which layer is active simply by click-
ing on the layer thumbnails in the Layers panel. 
When a layer is active, little white brackets will 
appear around its thumbnail. 

Fill a layer with color To fill a layer with a 
particular color, make sure the layer is ac-
tive, go to the Edit menu and choose Fill. 
A dialog box will appear giving you some 
options. Use the Contents menu to specify 
what color you’d like to fill with and then 
click OK. Note that if you have a selection 
active when using the Fill command, only 
the area inside the selection will receive 
the fill color. That’s what we’re going to do 
here in order to create that white box.

To create a new layer, click on the 
New Layer icon at the bottom of the 
Layers panel. 

The new, empty layer will be repre-
sented by a thumbnail filled with a 
checkerboard pattern. 

Here, we are using the fill command to fill 
the active selection. If there were no se-
lection active, it would fill the entire layer 
with the chosen color. 
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Changing opacity When you fill a layer 
or an area with a color, the color will be 
completely opaque (meaning you can’t 
see through it). If you would like to par-
tially see through the layer, use the Opac-
ity setting at the top of the Layers panel 
to lower the opacity of that active layer, 
making it partially transparent. The eas-
iest way of changing the Opacity is by 
clicking and dragging back and forth on 
the word “Opacity” at the top of the Lay-
ers panel. This will cause the setting to 
act like a slider.  

Adding text To add text, we’ll activate the Text Tool (located in the Tool Bar on 
the left side of the interface) and click in our document to place the cursor. By 
default, when we add text to a document, that text is placed on a new layer. We’ll 
then type in our text. The tool will remember the last settings used. If the text 
is too small or large (as it is in this case), we can highlight the text and then use 
the size setting located in the Options Bar above the main image window. You 
can change the size in the same way that we changed the opacity of a layer, by 
clicking on the Size icon and dragging left or right until the text is at our desired 
size. When we’re done setting the text, we can either click the little check mark 
in the Options Bar at the top of the screen, or we can click away from the layer in 
the Layers panel. 

Note: To select all of the text, make sure the cursor is somewhere in the text and 
then use the keyboard shortcut Command+A (Ctrl+A on Win). 

Copying an image from another document Now, we want to add another image 
to this document. We’ll open the other image as a separate window in Photoshop. 
There are a couple ways we can move an image or layer between documents. 
With the image we’d like to add open in Photoshop, we can go to the Select 
menu and choose All in order to select the entire contents of the layer. Then we’ll 

The Opacity slider/setting can be found at 
the top of the Layers panel. Use this setting 
to change the opacity of the active layer. 
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go to the Edit menu and choose Copy. Next, we’ll switch back to the document 
window where we want to add the image, we’ll go to the Edit menu and choose 
Paste. This will deposit the image in the current document as a new layer. 

Resizing a layer using the Free Transform Command The image is not the size 
that we want, so we’ll need to scale it and we’ll do this by using the Free Trans-
form command. The Free Transform command can be found under the Edit 
menu, but an easier way of accessing it is by using the keyboard shortcut Com-

mand+T (Ctrl+T on Win). Transform han-
dles will appear on the sides and corners 
of the layer and we can resize the image 
by clicking and dragging on these han-
dles. In order to maintain the proportions 
of the layer while transforming, we can 
hold down the Shift key. If we don’t do 
this, we can end up distorting the image. 
To lock in the transformation, we’ll click 
the Return or Enter key and the transform 
handles will disappear. 

The Move Tool & Auto-Select Layers To reposition the layer while using the Free 
Transform command, we’ll click somewhere within the picture (that is not one of 
the transform handles) and drag around the document. Otherwise, we will use 
the Move Tool to reposition the contents of a layer. If we’d like to move the layer 
perfectly horizontally or perfectly vertically, we can hold down the Shift key while 
dragging the layer. This will constrain the movement. 

With the Move Tool active, there is a setting 
we must be aware of because it will drastically 
change the way the tool works. The setting will 
appear on the left side of the Options Bar and 
it will either be represented as an icon or as an 
Auto-Select check box. If this setting is turned 
on, when you click your mouse button, it will 

Here, we are resizing a layer using the Free 
Transform command. You can see the Free 
Transform handles surrounding the layer. 

The Auto-Select setting in the Op-
tions Bar. This setting may also be 
represented as a check box. 
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look at what is directly beneath your cursor and it will target the layer that con-
tent is contained on. That means that Photoshop will automatically change what 
layer is active in the Layers panel when you click and drag your mouse. 

If the Auto-Select feature is turned off, then whenever you click and drag using 
the Move Tool, Photoshop will only target the active layer (regardless of where 
you click). It will not automatically switch between layers. The Auto-Select set-
ting is a personal preference, but I usually keep the feature turned off because I 
find that it can get in the way. For example, If I’d like to target a layer that is hid-
den under the content of another layer, I would have to move the overlying layer 
first because Photoshop will not be able to target the hidden one. 

Even if you keep the Auto-Select feature turned off, there is a way to temporarily 
access the setting when you need it. With the Move Tool active, I’ll hold down the 
Command key (Ctrl on Win) to temporarily turn on the Auto-Select Layers fea-
ture. When I release the key, it will be turned off again. 

Thinking about layers When it comes to layers, you can think of it as having a 
bunch of flat items on a table in front of you. Some of the items may be stacked 
such that they hide all or parts of the items beneath it. Each item is a layer, and 
the items on top will be at the top of the layers panel. Picture yourself standing 
at the top of the Layers panel and looking down. When you try to see the image 
that’s on the bottom layer, the content in the overlying layers will obstruct your 
view of it. 

The graphic above demonstrates 
how layers were used to con-
struct the image on the right. 
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Moving multiple layers at a time To work with multiple layers at once, we’ll have 
to select them in the Layers panel. To select more than one layer, we’ll click on the 
first layer you’d like to target, hold down the Shift key and then click on the last 
layer (providing we’re targeting layers that are all in a row).  Note this will only 
work if the Auto-Select setting is turned off. 

Toggle a layer’s visibility You can turn 
off the visibility of a layer by clicking 
on the eyeball icon to the left of the 
layer’s thumbnail in the Layers panel. 
This will not delete the layer. It will only 
hide it. Click on the square where the 
eyeball icon was to turn the visibility 
back on again. 

Note that when working with layers, many of the tools only work with one layer 
at a time. If we try to use the Move Tool to reposition the content on layer A, we 
need to make sure that layer A is active in the Layers panel. If a tool is ever not 
working in the way you think it should, check to make sure that you have the cor-
rect layer active and that its visibility is turned on.  

Some selection tools have a setting 
that enables you to target layers other 
than the active one, and that will ap-
pear as a “Sample All Layers” check 
box or icon in the Options Bar above 
the image window. 

Copying/duplicating a layer There are a couple ways of duplicating a layer, or 
part of a layer, and we must make sure that the layer we want to copy from is 
active in the Layers panel. Note that if there is a selection active, we will only 
duplicate the content within that selection and not the entire layer. That’s what 
we’re doing in the video example. We created a selection around the church and 
we want to copy it to its own layer. One way of doing this would be going to the 

We turned off the visibility of the top layer by 
clicking on the eyeball icon to the left of the 
thumbnail. 

The Sample All Layers setting will allow the 
active selection tool to work with more than 
one layer at a time. 
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Layer menu and choosing New > Layer via Copy. We can also use the keyboard 
shortcut Command+J (Ctrl+J on Win) to achieve the same result. 

Renaming a layer When you start to get multiple layers in your document, it’s a 
good idea to start naming your layers. This will help you to identify what each 
layer’s purpose is or what it contains. To rename a layer, double-click on the name 
of the layer and the name will become highlighted. You can then type in the new 
name and hit the Return or Enter key. 

Changing the layer stacking order You can 
change the order of your layers by clicking 
and dragging up or down on a layer in the 
Layers panel. When you do this, Photoshop 
will give you feedback to show you where the 
layer will be positioned when you release the 
mouse button. 

Aligning layers If we’d like multiple layers to line up with each other, we’ll first 
need to select all of the layers in the Layers panel and make sure that the Move 
Tool is active. When the Move Tool is active, a series of icons will appear in the 
Options Bar above the main image window and these are the alignment settings. 
We can choose to align the selected layers by their top edge, center line hor-

izontally, center line vertically, etc. If 
you hover your cursor over each of 
the icons, a little box will appear tell-
ing you what that alignment setting 
does. In the video example, we select-

Here, we made a selection around 
the church in the background lay-
er and used the keyboard shortcut 
Command+J (Ctrl+J on Win) to copy 
the contents of the selection onto a 
new layer. 

We’re changing the stacking order by 
dragging a layer to a new position. 

The Align icons in the Options Bar. 
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ed the white box, the text and the church so that we can center them. To do this, 
we chose the Align Horizontal Centers icon. 

Using the Move Tool to move a layer between documents We already talked 
about how we can copy and paste a layer between documents. Now let’s look at 
how we can use the Move Tool. We’ll open the document containing the image 
we’d like to move into another document. With the Move Tool active, we’ll click 
within the document and drag so that our mouse hovers above the Photoshop 
tab for the target document (without letting go of the mouse button). Photoshop 
will automatically switch to the other document. Now, we’ll move the mouse into 
the target document and release the mouse button. If the document we move 
from is a different size than the document we move to, then the image we move 
will appear to be a different size in the document we placed it in. 

Moving images into a document from Bridge We can drag images into our Pho-
toshop document from Bridge by first selecting the image or images we’d like to 
add and then dragging them directly into our Photoshop window. When we re-
lease the mouse button, the first image will be placed in the document with active 
free transform handles for scaling. If the image was larger than the document, it 
will automatically be scaled to fit. After we scale the image to our liking, we can hit 
the Return or Enter key to lock in the transformation. When we do this, the next 
image we dragged over will now appear with the same free transform handles. 
We will continue to scale the images and hit Enter/Return until all the images we 
dragged over were scaled and placed as separate layers in our document. 

Here, we are dragging 
multiple images from 
Bridge directly into our 
Photoshop document. 
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Clipping masks A clipping mask can be used to make the contents of one layer 
appear within the confines of the layer that’s directly beneath it. One of the many 
things we can do with this feature is make it look as if a photograph is appear-
ing inside of some text. That’s what we’re going to do in the video example. We’ll 
start by making sure the text layer 
is directly beneath the photo layer 
that we want to appear inside of the 
text. We’ll also reposition the pho-
to layer so that it covers the text. 
With the photo layer active, we’ll go 
to the Layer menu and choose Cre-
ate Clipping Mask. When we do this, 
the thumbnail for the photo layer 
will become slightly indented and a 
little down pointing arrow icon will 
appear to the left of it. This indi-
cates that the layer is clipped to the 
layer beneath it and that layer will 
only show up where you can see in-
formation in the layer below. 

Clipping masks can be used for all kinds of 
things. Another use would be clipping an ad-
justment layer so that it only affects the layer 
beneath it. We could also use them to paint on 
an empty layer while ensuring that we don’t get 
paint outside the confines of the layer beneath 
it. In the video example, we created a blue circle 
on one layer and we started painting with black 
(using a lower opacity setting) on an empty 
layer above it for the purpose of adding shad-
ing to the circle. When doing this, we got a lot 
of overspray, where paint was applied outside 

When we create a 
clipping mask, the 
layer that is clipped 
becomes indented 
in the Layers panel. 
At left, the photo 
now appears to be 
contained within 
the word Iceland. 

We are using the Brush Tool (with a 
lower opacity setting) on an empty 
layer to create shading in the orb.
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of the blue circle. To fix this, we clipped the paint layer to the circle layer beneath 
it so that the paint only shows up over the circle. Note that we can clip multiple 
layers in a row to one underlying layer. 

Layer Groups/Folders After creating a complex document that includes a lot of 
layers, the Layers panel can start to look a bit messy. Let’s look at how we can or-
ganize the Layers panel to make our work in Photoshop a little easier. Photoshop 
allows us to organize our layers into folders. You can see the folder icon at the 
bottom of the Layers panel. To place layers into a folder (or group, as they’re in-
terchangeably called), first select all of the layers you would like in the folder and 
then click on the folder icon at the bottom of the Layers panel. All of the selected 
layers will then be placed inside a layer group that will be condensed inside of the 
Layers panel. Click on the arrow to the left of the folder icon to expand it and see 

its contents. Double-click on the 
name of the folder to change the 
name. It’s always a good idea to 
do this so you know what the 
group’s purpose is even when 
it’s not expanded. 

The layer with the shading was clipped to 
the orb layer. This prevented any overspray 
from being visible in the background.

The Folder/Group icon at the bottom of the Layers 
panel.
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When you have layers in a group, you can use the Move Tool to move all of the 
layers at once. To do this, just make sure that the name of the group is active in 
the Layers panel and then use the Move Tool to reposition the entire contents of 
the folder. 

Layers and file formats When you save your document, it’s important to know 
that there are only two file formats that support layers. If you save your document 
as a psd file or a tiff file, then your layers will stay intact and the next time you 
open your document, it will appear exactly the same as when you last worked 
with it. If you save your doc-
ument as a different file 
format, jpeg for example, it 
will be saved as a flat docu-
ment and the layers will not 
be maintained. If you have a 
multi-layered document and 
you choose jpeg in the Save 
dialog, you will see a little 
warning symbol at the bot-
tom, letting you know that 
the layers will not be saved.

The Background Layer When we open an image in Photoshop, the image layer 
(which will be the only layer) is called Background. We can add as many addi-
tional layers as we’d like, but the bottom layer will be called Background (unless 
we do something to change it). This is a special layer that will have some limita-
tions. For example, you can’t delete parts of the background layer. If you attempt 
to use the Eraser Tool on the background layer, the area will be filled with the 
background color (instead of being erased). Additionally, the background layer 
can not extend beyond the bounds of your document. You also can not place any 
other layers beneath the background layer. It will always be at the bottom of your 
document. 

If you try to save a multi-layered document in a file for-
mat other than PSD or TIFF, you will get the above warn-
ing symbols in the Save dialog. PSD and TIFF are the only  
file formats that support layers. 
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If your document does not have a background layer, the contents will be con-
verted into a background layer when you save the document using certain file 
formats (the ones that don’t support layers). You can also flatten your entire doc-
ument into a single background layer by choosing Layer > Flatten. 

If you would like to convert the background layer into a normal layer, simply click 
on the lock symbol to the right of the name “background layer.” Additionally, if 
you change the name of the background layer, it will be converted into a regular 
layer. 

Revert This command will bring your document back to the state it was in when 
you first opened it. You can access this command by going to the main menu at 
the top of the interface and choosing Image > Revert.


