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Color Range

In this lesson, we’re going to learn how to use the Color Range command to make 
selections in Photoshop. The Color Range command has been available in Photo-
shop for a really long time, and I use it on a regular basis. 

The Color Range command can be found under the Select menu at the top of 
Photoshop’s interface. When the settings dialog appears, it will remember the 
last settings you used when working with the Color Range feature. 

Let’s start with some initial settings. At 
the top of the Color Range settings di-
alog is the Select menu, and it’s a good 
idea to choose the Sampled Colors op-
tion here. Set the menu at the bottom 
of the dialog (the Selection Preview 
menu) to None (as a starting point). 

Now let’s look at how Color Range 
works. When you have the Color Range 
dialog open, you can hover your mouse 
over the image and the cursor will ap-
pear as the Eyedropper Tool. This is be-
cause the “Sampled Colors” option is 
chosen via the Select menu at the top 
of the dialog. Use the Eyedropper to 
click on the color you want to sample 
within the image. When you click on a 
color, a preview will appear within the 
Color Range dialog. This preview represents a mask, where white areas are se-
lected and black areas are not selected. You can switch between viewing the 
preview window as a selection (the black and white view) or viewing it as the ac-

The Color Range dialog box. The settings 
shown above are a good starting point for 
selecting a color. 
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tual image by clicking on the “Selection” and “Image” settings below the window. 
Holding the Command Key (Ctrl on Win) will temporarily toggle between the two 
views for this preview window. 

The preview window within the dialog box is pretty small, so it can be hard to get 
a sense for what is selected and what isn’t. You can change the view of your main 
image window by using the Selection Preview menu at the bottom of the dialog. 
Setting this menu to the “Grayscale” option will make the image window display 
the black and white mask view. Setting this menu to the “Black Mask” option will 
make the unselected areas black and the selected areas look normal. You can also 
choose to display the opposite view by turning on the Invert check box on the 
right side of the dialog. This will make all selected areas black and the unselected 
areas look normal. I like this view and will use it a lot in this lesson.

Both screen shots above show the Color Range feature being applied where we used the 
sampling eyedropper to click on the blue hats. At left, the Selection Preview menu was set to 
Black Matte. Everything is black except for the selection. In the screen shot at right, we still 
have the Black Matte preview option chosen, but we turned on the Invert check box so that 
the selected areas have the black overlay.
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After you have clicked on the image once to 
sample a color, you can expand the range 
of colors targeted in one of two ways. The 
first is via the Fuzziness slider near the top 
of the Color Range dialog. Fuzziness deter-
mines how far the selection can vary, or de-
viate, from the color you originally clicked 
on. As you move this slider more and more 
to the right, it will be able to include a larg-
er and larger color range in the selection. 
As you move the slider lower and lower, it 
will start to isolate only the colors very sim-
ilar to the one you clicked on. 

You can also expand the range of colors 
being selected by using the three Eyedrop-
per icons on the right side of the Color 
Range dialog. The Eyedropper on the left is 
the default and it will allow you to change 
the color you’re attempting to select. The 
second Eyedropper has a plus sign next to 
it, and it allows you to sample more than 
one color within the image. With this eye-
dropper active, you can click in multiple ar-
eas of the image to expand the selection 
to include the colors you click on. The third 
eyedropper has a minus sign next to it and 
clicking on the image with this eyedropper 
will exclude colors from the selection. 

Moving the Fuzziness slider up will  
expand the selected color range.

Clicking within the image using the plus 
eyedropper will add colors to the  
selection.
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Color Range in Action: Hat Image

Let’s walk through the steps I would take in using the Color Range command to 
make a precise selection. We’ll use the example image with the vibrantly-colored 
hats. We’ll open the dialog by clicking on the Select menu at the top of the screen 
and then choosing Color Range. The left-most eyedropper is selected by default, 
and this is the one used to target the color we want to select. We want to select 
the blue hats, so we’ll use this eyedropper to click on one of them. Then, we’ll 
drag the Fuzziness slider to a very low setting (around 10). This means that the 
selection will not be able to deviate very much from the color we clicked on. 

Next, we’ll activate the eyedropper with the plus sign and use it to click on more 
areas of blue, adding more and more shades of blue to the selection. We can see 
the preview changing in the small window within the Color Range dialog, but it’s 
too small to see very well so we’ll change the Selection Preview menu to Black 
Matte. This will change the view of the main image window, showing black in all 
areas that are not selected and showing the normal colors of the image in the ar-

eas that are selected. We 
want to view the oppo-
site of this, where the 
black overlay is on the 
areas that ARE selected, 
so we’ll turn on the Invert 
check box on the right 
side of the Color Range 
dialog. While in this view, 
we’ll continue to use the 
plus eyedropper to click 
on the different areas of 
blue in the hats until more 
of the hats have the black 
overlay, indicating that 
they are selected. 

We’re using the plus eyedropper to click on different parts of 
the blue hat so the selection includes enough shades of blue 
to select most of the hat. We’re using the Black Matte Selec-
tion Preview with the Invert check box turned on, so a black 
overlay appears in all areas that are selected.
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There will be some objects that will be difficult to select using the Color Range 
command and those are the ones that have really bright highlights and/or really 
dark shadows. As the highlights get brighter and brighter, they will contain less 
and less color. A specular highlight will contain no color at all. The same goes for 
shadows. The darker the shadow, the less color it will contain. In order for the 
Color Range command to make an accurate selection, it needs to have colors to 
target. If we try to click on one of the bright highlights with the Color Range eye-
dropper, it’s going to select too much of the image because it’s going to look at 
all areas that contain little color. 

The Selection Preview menu contains more options that can be useful for pre-
viewing the selection we have created. We previously had this menu set to Black 
Matte, which placed a black overlay over all areas that were not selected. We 
could also choose the White Matte option, which places a white overlay over all 
the areas that are not selected. Again, we can turn on the Invert check box to 
get the opposite, where all the selected areas will have a white overlay and all 
non-selected areas will look normal. The Quick Mask preview option will put a red 
overlay on the image, allowing us to preview the selection as if we were in Quick 
Mask Mode, with all selected areas appearing normal and all unselected areas 
covered with a red overlay. 

The Quick Mask 
Selection  
Preview option 
places a red 
overlay over all 
areas that are 
not selected.
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After selecting as much of the tar-
get color as possible, we’ll tweak 
the Fuzziness slider to make the 
selected color range larger or 
smaller as necessary. I like to move 
this slider to the highest setting 
that still isolates the color that I 
want. When we’re done, we’ll click 
OK to exit the Color Range dialog. 

Now we’ve got the hats selected, 
but it’s not the exact selection that 
we want because we still need to 
include the deep, dark shadows. 
We’ll need to further refine the se-
lection and we can do so by tapping the Q key to enter Quick Mask Mode. This 
will place the red overlay over all areas that are not selected. In Quick Mask Mode, 
we can use the Brush Tool to make changes to the selection. Painting with black 

will take away from the 
selection (adding red 
overlay) and painting 
with white will add to the 
selection (removing the 
red overlay). We’ll paint 
with white over the dark 
areas of the hats so that 
they’re completely se-
lected. We’ll tap the Q 
key again to exit Quick 
Mask Mode. 

Here, you can see the selection that we created 
using the Color Range command. The blue hats are 
now mostly selected.

We’re in Quick Mask Mode, using the Brush Tool to paint with 
white over the parts of the hats that still need to be selected.
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Decorative Dragon Image

In this example, we want to use the Color Range command to select the blue 
areas in the image. Part of the paint on this decorative dragon has become fad-
ed and blue instead of its original gold. We want to target this faded blue (and 
sometimes white) area so that we can make it gold again. We’ll click on the Se-
lect menu and choose Color Range. The Color Range dialog remembers the last 
settings used, so it will select the color that we targeted in the last image and 
the preview option chosen. When starting a new selection, I find it’s easier to tar-
get the initial color when the Selection Preview menu is set to None. This lets us 
see the regular image without any overlay on it. The left eyedropper is active by 
default and we’ll use it to click on part of the faded, blue area in the decoration. 

The default eyedropper was used to click within the faded part of this decoration, making an 
initial selection. We’re using the Black Matte preview, with the Invert check box turned on so 
that the selected areas are covered with a black overlay.
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Then, we’ll use the eyedropper with the plus sign to click in additional areas that 
contain the color range we want to target. While using the default eyedropper 
tool, you can hold down the Shift key to temporarily access the plus eyedropper 
so that you can use it to expand the selected color range. When you release the 
Shift key, it will go back to the regular eyedropper. We can adjust the Fuzziness 
slider to better see the preview within the Color Range dialog, but it’s really too 
small to accurately see the selection. We’ll set the Selection Preview menu to 
Black Matte and then turn on the Invert check box so that the black overlay only 
covers the areas that ARE selected. With this better view, we’ll continue to use 
the plus eyedropper to click on the areas where the paint has faded, adding to 
the selection. 

When we’re satisfied with the selection, we’ll first turn off the Invert check box 
and then click OK to exit the Color Range dialog. We turn off the invert check 
box because we only wanted the preview to be inverted, not the actual selection. 

After closing the Color Range dialog, we can see the resulting selection. The selection edges 
are very harsh, so we’ll need to refine the selection further.
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Looking at the resulting selection, the selection edges are not soft enough so we’ll 
need to refine the selection further. We’ll click on the Select menu and choose 
Select & Mask, as this is a feature that can help us create softer transitions in our 
selections. The Select & Mask window will open and we can use the View menu 
on the left to decide what the preview should look like in the main window. We’ll 
choose the Overlay option because it looks like the red Quick Mask Mode preview. 

Now, we’re going to work with the Radius slider on the left side of the window. 
This setting is going to give Photoshop control over the edges of the selection. 
The higher we move the slider, the larger of an area (around the selection edges) 
Photoshop will have control of. It’s great for selecting things that are fuzzy, hairy, 
have complex edges or simply fade out gradually. We’ll drag this slider up until 
the selection edges appear smooth instead of jagged. When we’re satisfied, we’ll 
click the OK button at the bottom of the window to exit the Select & Mask feature 
and go back to Photoshop’s main interface. 

Here, we’re using the Select & Mask feature to refine the selection. We’re moving the Radius 
slider up, which is creating a softer transition in the selection edges.
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The selection is now much smoother and we can use it to apply adjustments to 
the image. We’ll click on the Adjustment Layer icon at the bottom of the Layers 
panel and choose Photo Filter from the menu that pops up. The settings for the 
Photo Filter adjustment layer will appear inside the Properties panel. Because we 
had a selection active, this selection was automatically applied to the layer mask 
attached to the adjustment layer. All of the selected areas represent the white 
part of the mask, which is the part that will allow the adjustment to be visible. 
With Photo Filter, we can choose a color that we want to push into the image, by 
selecting the Color option and then clicking on the rectangular color swatch to 
open the Color Picker. 

Now it would be nice to be able to choose a 
color by sampling from another area in the 
image (an area where the gold is not faded). 
But we can run into an issue with that. In or-
der for us to be able to sample a color from 
within the image, the mask can not be the 
part that’s active. When we create an adjust-
ment layer, the mask is active by default. The 
mask only contains black, white and shades 
of gray, so that’s all the eyedropper will see 
if it’s the mask that’s active. We want the 
eyedropper to be able to see the gold hues 
in the image. To get this, we need to make 
sure that the layer is active and not the mask. 
We’ll simply click on the adjustment layer’s 
thumbnail in the Layers panel so that the lit-
tle white brackets appear around the layer 
and not the mask. For an adjustment layer, 
the layer thumbnail simply looks like the icon 
for the chosen adjustment layer. 

In the top screen shot, the mask is ac-
tive. In the screen shot directly above, 
the layer itself is active. You can switch 
between making the two active by 
clicking on the thumbnails.
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When the layer is active 
(and not the mask), the 
eyedropper within the 
Color Picker will be able 
to see the actual colors 
in the image. We’ll use 
this to choose a gold 
hue from part of the 
decoration that is not 
faded. We’ll click OK 
to exit the Color Pick-
er. Now we can use the 
Density slider (within 
the Properties panel), which will control how much of the chosen color we are 
pushing into the image. We’ll drag the slider up, watching the effect in the faded 
areas we had previously selected. The Preserve Luminosity check box will make it 
so the effect can ONLY change the color and not the brightness of the targeted 
area. It’s a good idea to experiment with this setting, turning it on and off to see 
how it looks with the image. 

Here, we’re using the eyedropper within the Color Picker to 
sample part of the image that has the right shade of gold.

The Photo Filter adjust-
ment layer is being used 
here. After the gold color 
was selected, you can see 
it being pushed into the 
image in the areas that 
were selected. You can no 
longer see the faded blue/
white parts. 
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Sunset image

In the next example image, I’d like to use the Color Range feature to select the 
blue areas of the sky so that I can adjust it using an adjustment layer. We’ll click on 
the Select menu and choose Color Range. In the Color Range dialog, we’ll start by 
setting the Selection Preview menu to None. We’ll end up changing that later, but 
it’s nice to start off by seeing the actual image. We’ll use the default eyedropper 
tool to click within a blue area of the sky. This will make the initial selection and 
we can see a preview of that selection in the small preview window in the Color 
Range dialog. This did a pretty good job of selecting all of the blue. We’ll refine 
the selection by adjusting the Fuzziness slider, changing the Selection Preview 
menu if we’d like to see the preview in the main image window. We’ll click OK and 
we can see the “marching ants” selection appear over the image. 

The Color Range command is being used to select the blue areas in the sky. The Black Matte 
preview is being used, with the Invert check box turned on, so the selected areas have a 
black overlay.
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I’d like to make changes to this se-
lected blue area so we’ll click on the 
Adjustment Layer icon at the bottom 
of the Layers panel and choose the 
Photo Filter adjustment layer. We’ll 
click on the Color option within the 
Properties panel and set the color to 
orange (a color resembling the sun-
set). Remember, if you ever want to 
use the Color Picker to sample a col-
or from within the image, the layer it-
self will need to be active, and not the 
layer mask attached to the layer. We’ll 
drag up the Density slider to adjust 
how much of this color is pushed into 
the image. 

Looking at the image, we can see that 
it added the orange color to areas 
in the foreground as well. We don’t 
want this, so we’ll need to adjust the 
layer mask, which is controlling where 
the adjustment layer is visible. With 
the layer mask active, we’ll use a soft, 
black brush and paint over the low-
er part of the image, where we don’t 
want the color adjustment to be vis-
ible. 

The Photo Filter adjustment layer is being used 
to push an orange color into the selected areas. 

The Brush Tool is being used to paint on the 
layer mask attached to the adjustment layer, 
removing the orange hue from the foreground.
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Sculpture garden image

The Color Range command can be used to make a selection of a really complex 
object, as long as it’s surrounded by a different color. In the next example image, 
we have a very complex structure covering this garden. Because it’s white, against 
a blue sky, we can make a selection of it using Color Range. What we’ll actually 
do is create a selection of the blue sky and then invert the selection so that it iso-
lates the white structure and foreground structures. We’ll go to the Select menu, 
choose Color Range and within the Color Range dialog, we’ll again set the Selec-
tion Preview menu to None. We’ll use the default eyedropper tool to click within 
the dark area of the blue sky. Then, we’ll hold down the Shift key to temporarily 
access the plus eyedropper and we’ll click in a lighter area of the sky to expand 
the range of blues that are being selected. We’ll do this again for an even lighter 
part of the sky. Looking at the preview within the dialog box, we can see that 
we’re now targeting the entire sky area. We’ll make sure the Fuzziness slider is at 
a low setting so that it’s not deviating too far from the targeted color and then 
we’ll set the Selection Preview menu to Matte Black. We’ll turn on the Invert check 
box so that the black over-
lay is covering everything 
that is selected. In this 
view, we’ll continue to use 
the plus eyedropper to add 
as much of the blue sky to 
the selection as is possible. 
When doing this, it’s com-
mon to go back and forth 
between the eyedroppers 
and the Fuzziness slider in 
order to get as much of the 
desired color selected as 
possible without selecting 
too much extra. 

We’ve used a combination of the eyedroppers and the 
Fuzziness slider to select the sky area of the image.
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When we have a good selection of the sky, 
we’ll leave the Invert check bot turned ON 
and then click OK to exit the Color Range 
dialog. By leaving the Invert check box 
turned on, the selection was inverted to in-
clude everything EXCEPT the blue sky, and 
this is what we want. We’ll turn this selection into a layer mask by clicking the 
Layer Mask icon at the bottom of the Layers panel. Everything that is selected will 
become the white part of the layer mask, which is the part that is allowed to be 
visible. Everything that was not selected will be black in the layer mask and will 
therefore be hidden. 

The view we have now is the white structure against the transparent, checkered 
background. We’ll put something behind this layer so that we can better see 
what’s going on. We’ll click on the Adjustment Layer icon at the bottom of the 
Layers panel and choose to create a Gradient Fill layer. A dialog will appear and 
we’ll use the Gradient menu to choose a gradient that contrasts from the image 
layer, just so that it’s easy for us to see the masked layer better. We’ll click OK 
to close the Gradient Fill dialog and then drag this new Gradient Fill layer to the 
bottom of the layer stack, beneath the image layer. 

Now that we can see the layer on a contrasting background, we can see that there 
are some problems with the sculpture in the foreground, middle area of the image. 
The Color Range is good as selecting colors, but this object varies in both color 
and brightness, so Color Range is not going to be the best tool to select it with. 

We’re going to turn off the layer mask so that 
we can see the entire image layer and we’ll do 
that by holding the Shift key and clicking on the 
layer mask icon in the Layers panel. A red X will 
appear over the thumbnail, indicating that the 
mask is temporarily inactive. Then, we’ll activate 
the Quick Selection Tool because it’s a tool that 
is good at selecting objects. Using this tool, we’ll 

The selection was converted into a layer 
mask.

The gradient layer was placed on 
the bottom and we temporarily 
deactivated the layer mask.
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click and drag within the sculptural object, making sure that we don’t get any 
overspray with the selection. If we DO get overspray, we can change the Quick 
Selection tool so that it subtracts from the selection (instead of adds to it) by 
clicking the icon within the Options Bar that looks like a brush with the minus sign 
next to it. With the Quick Selection Tool set to subtract, we’ll paint over the ar-
eas that were accidentally selected. With the object selected, we’ll turn the layer 
mask back on by holding the Shift key and clicking on the Layer Mask’s thumbnail 
within the Layers panel. 

In a layer mask, white makes things show up and black hides them, so we’re going 
to fill the selection with white. We’ll click on the Edit menu and choose Fill. When 
the Fill dialog appears, we’ll set the Contents menu to White and then click OK. 
We can then deselect. 

LEFT: The Quick Selection 
Tool is being used to select 
the star-shaped structure so 
that we can use the selec-
tion to make changes to the 
layer mask.

ABOVE: You can set the 
Quick Selection Tool to 
subtract from a selection by 
clicking the minus icon in 
the Options Bar.
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Looking at the results, the edges of the white structure don’t seem smooth 
enough, so we can adjust the mask even further. We’ll click on the Select menu 
and choose Select & Mask. In the Select & Mask window, we’ll set the View menu 
to “On Layers” so that we can see the masked layer against the layer beneath it in 
the Layers panel (the gradient layer). We’ll drag the Radius slider up a bit, giving 
Photoshop more control over the edges of the selection, and then we’ll click OK 
to exit the Select & Mask window. 

LEFT: You can see that the Color Range command did not do a good job of selecting this 
structure. RIGHT: We made a selection of the structure and then filled the layer mask with 
white, making it so the entire structure was visible.

The Select & Mask 
feature is being 
used to smooth the 
selection edges. 
The Radius slider, 
on the left side of 
the window, helps 
to do this.
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Tulsa Oil Man image

In the next example image, we have a large yellow sculpture and I’d like to bring 
out the detail in that sculpture so we’ll first need to make a selection of it and we’ll 
use the Color Range feature. 

NOTE: If I wanted to alter the color of the sculpture, I would instead use a Hue/
Saturation adjustment layer because it does a great job of isolating and making 
changes to a specific color in an image. 

We’ll click on the Select menu, choose Color Range and then make sure that the 
Selection Preview menu is set to None. With the default eyedropper, we’ll click 
somewhere within the yellow sculpture and then we’ll hold the Shift key to tem-
porarily activate the plus eyedropper so that we can click in more areas to ex-
pand the range of color being selected. With the plus eyedropper active, we can 
also click and drag within the yellow area, making sure that we don’t drag over 
any areas that have bright highlights. Clicking on the bright highlights with the 
eyedropper would cause too much of the image to become selected. 

The Color Range command is being used to target the yellow color in this image so we can 
make a selection of the sculpture.
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Next, as usual, we’ll change the Selection Preview menu to Black Matte and turn 
on the Invert check box so that the black overlay covers the area being selected. 
With this view, we can further refine the selection by using the plus eyedropper 
to click on yellow areas that have not yet been selected. The areas that are the 
deepest shadows are going to be difficult to add because there is very little color 
in these areas. If we attempt to select these areas, we may find that we get oth-
er parts of the image selected as well. Once we have as much of the sculpture 
selected as possible, we’ll adjust the Fuzziness slider, moving it to the highest 
setting that still selects only the sculpture. At this point, it can be useful to switch 
between the Selection Preview options, finding the one that gives us the best 
preview of the selection. 

Now, we don’t truly want to invert the selection, so we’ll turn off the Invert check 
box in the Color Range dialog and then click OK to close the dialog box. 

Now, we’ll modify the selection in Quick Mask Mode. We can turn on Quick Mask 
mode by tapping the Q key and the red overlay will appear in all areas that are 
NOT selected. We can refine the selection in a variety of ways, but in this case, 
we’ll use the Brush Tool, painting with white over the areas that should be select-
ed. When we paint with white, we are removing the red overlay in Quick Mask 
Mode and therefore adding to the selection. 

We’re viewing the 
selection in Quick 
Mask Mode, where a 
red overlay is placed 
over the parts of 
the image that are 
not selected. We’re 
painting with white 
to add areas to the 
selection.
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When the selection looks accurate, we’ll tap the Q key again to exit Quick Mask 
Mode. We can see the “marching ants” selection active over the image. To add 
texture to this selected area, we’re going to click on the Filter menu and choose 
the Camera Raw Filter. In the newest version of Camera Raw, a new Texture slider 
was added and it can be found within the Basic panel, which is the left-most icon 
beneath the Histogram. The Texture slider is located just above the Clarity slider 
and we’ll drag this slider far to the right, adding texture and detail to the selected 
area. If this doesn’t add enough texture, we can also increase the Clarity setting 
a bit and then click OK. 

With the selection of the sculpture active, we opened the Camera Raw filter and are increas-
ing the Texture slider to make the selected area pop a bit more.
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Skydivers with smoke image

The next image contains 
some skydivers making 
shapes of yellow smoke. 
We’re going to select 
the smoke, so we’ll click 
on the Select menu and 
choose Color Range. 
We’ll use the default eye-
dropper to click on part 
of the yellow smoke and 
then hold down the Shift 
key to temporarily access 
the plus eyedropper. We’ll 
click on another area of the yellow color with the plus eyedropper to widen the 
color range, selecting more of the smoke.  Once the smoke is selected, we’ll click 
the OK button to exit the Color Range dialog. (Remember, if we were using the 
Black Matte preview with the Invert check box turned on, we would have to turn 
the Invert check box OFF before clicking OK so that the selection would not be 
inverted as well.) 

With the selection active, we’ll click on 
the layer mask icon at the bottom of 
the Layers panel. The selection will be 
applied to the mask, where everything 
that was selected will be white (visi-
ble) and everything that was not se-
lected will be black (hidden.) We can 
refine the mask by painting on it with 
the Brush Tool. We’ll use a black brush 
and paint over any areas that still need 
to be hidden. 

The Color Range feature is being used to make a selection of 
the yellow smoke. 

With the selection active, we clicked the Layer 
Mask icon to mask the layer so that the smoke 
is the only part that’s visible.
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Localized Color Clusters

The Localized Color Clusters check box is located at the top of the Color Range 
dialog box. Let’s look at what it does by applying the Color Range command on 
an image that is made up of one solid color. We’ll use the default eyedropper to 
click within the image to make a selection of the color, which will encompass the 
entire image. We’ll also set the Selection Preview menu to Black Matte and then 
turn on the Invert check box so that all the selected areas have a black overlay. 

We’ll turn on the Localized Color Clusters check box and we’ll only see a little 
change in the preview box.  In order to see more of a change, we need to move 
the Range slider down. (It’s set to 100% by default.) As we move the Range slider 
farther and farther to the left, the radius containing the selected area becomes 
smaller and smaller, shrinking down toward the very spot where we clicked the 
mouse using the default eyedropper selection tool. 

If we click in additional areas using the plus eyedropper and we have the Range 
setting very low, it will only select areas that are local to where we clicked with 
the eyedropper tool. 

This image con-
tains a solid color, 
so clicking with 
the eyedropper 
will select the 
entire image. Here, 
we turned on the 
Localized Color 
Clusters check 
box and move the 
Range slider far 
to the left. This 
caused the selec-
tion to be local-
ized to the areas 
where we clicked 
with the eyedrop-
per.
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The Range slider controls how far from the clicking point can the selection ex-
tend. This setting can be useful when you have an image containing more than 
one object of the same color but you only want to select one of the objects. 

Let’s look at the benefit to the Localized Color Clusters check box in this im-
age containing many shoes. We want to select a single red shoe using the Color 
Range command. We’ll use the default eyedropper to click on the red shoe we 
want selected and then continue with the plus eyedropper to make sure the ap-
propriate range of red is selected in order to get all parts of the shoe selected. 

To get a better view of what’s be-
ing selected, we’ll change the Se-
lection Preview to Black Matte and 
then turn on the Invert check box 
so that the black overlay only cov-
ers the areas being selected. We’ll 
use the plus eyedropper to make 
sure that the range of red being se-
lected is wide enough. We can also 
tweak the Fuzziness slider to refine 
the selection.

As we drag the 
Range slider to the 
right, the selection 
can expand farther 
and farther from 
the spots where 
we clicked with the 
eyedropper.

The Color Range command is being used to select 
the reds.
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Looking at the preview, we can see that this selected all of the red shoes in the 
image. We only want to select one, so we’ll turn on the Localized Color Clusters 
check box and then move the Range slider to the left until only the shoe we ini-
tially clicked on is selected. 

The Select menu

At the top of the Color Range dialog is the Select menu. It’s set to the choice of 
“Selected Colors” by default, which refers to the colors that were clicked in the 
picture using the eyedropper. This is the setting I use 90% of the time. 

This menu also contains multiple color options. If we choose one of these colors, 
Reds for example, it will select everything in the image that is red, but we won’t 
have additional control over the selection with other settings like the Fuzziness 
slider. This may be less useful than the eyedropper sampling method in most 
cases, but the instance where it would be very useful is in the creation of actions. 

The Range slider 
was moved to the 
left until only the 
red show we origi-
nally clicked on was 
selected.
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When used in actions, most selection tools require the user’s interaction in order 
to complete the action. That’s not the case with the Color Range feature IF one of 
these color options is used. Instead of asking the user to specify a color, we can 
tell the action to automatically target the color used in this menu when creating 
the action. 

The Select menu can be used to target a specific set of colors, but no additional settings will 
be available for refining the selection. 
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Add more than one color Up until now, we’ve been using the Color Range fea-
ture to select a single color in the image. We can select more than one color by 
running the Color Range command more than once. To do that, we’d need to 
start by using Color Range to make a selection of the first color and then clicking 
OK to close the dialog. With the selection still active, we can hold down the Shift 
key WHILE we click to open the Color Range dialog a second time. The initial se-
lection will already be active and we can use the Color Range settings to select 
another color, adding to the selection. 

If we select a color using one of the color options in the Select menu and then we 
close the Color Range dialog, we can return to the dialog (with the selection still 
active), change the Select menu to another color and it will add that color to just 
the selected area. 

Selecting Highlights, Midtones and Shadows The Select menu also contains the 
options of Highlights, Midtones and Shadows, and I find these to be really use-
ful. Let’s say we want to select all of the shadows in the image. We’ll choose the 
Shadows option from the Select menu and then use the Range slider to deter-
mine what is considered a shadow. As we move this slider more and more to the 
right, more and more tones will be considered to be shadows and will be included 
in the selection. The Fuzziness slider can then be used to determine how far the 
selection can deviate from the chosen tonal range. Again, this is another feature 
that is great for use in actions. Using this, an action can isolate the highlights, 
shadows or mid-tones in an image without input from the user. 

Under the Select menu, there is also an option titled “Out of Gamut” and this 
would select any colors that would shift if the document were to be converted 
into the CMYK mode. 

Another option under the Select menu is titled “Skin Tones” and this would at-
tempt to select any skin tones in the image. With this option chosen, the “Detect 
Faces” check box becomes available. Turn this on and the Color Range command 
will attempt to look for facial features and attempt to add them to the selection. 
I find that this feature can tend to function in a less-than-optimal way. 


