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Aligned Retouching 

In this lesson, I’m going to show you how I tackled a challenging retouching job 
using the Healing Brush, the Transform command and the Puppet Warp feature in 
Photoshop. 

The top photo shows the finished image, with all the retouch work done. Directly above, you 
can see some of the elements I retouched out: The piping and the bench.
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Retouching out the piping

The first thing I want to do is remove the distracting piping from the side of the 
building. When working on a retouching task like this, I like to sever the object I’m 
removing from its surroundings using the Clone Stamp Tool, ensuring that the ob-
ject is surrounded with the kind of content I want to use to fill in the area. In this 
instance, I want to create a gap between the clean area of pipe and the area where 
it converges with the horizontal ledge of the building. By isolating part of an object, 
it’ll make it easier to remove using the Healing Brush. 

To start, I’ll create a new, empty layer 
and do all the retouch work on that 
layer. Note that when using the re-
touching tools while working on an 
empty layer, it’s important that the 
Sample setting in the Options Bar 
is set to Sample All Layers or set to 
Sample Current & Below. This allows 
Photoshop to look at the content on 
the underlying layers when working 
with the retouching tools. 

With the Clone Stamp Tool active, 
I’ll hold down the Option key (Alt on 
Win) and click on the area I want to 
sample (an area just to the side of 
the pipe I want to remove). Then, I’ll 
release the Option key and use the 
Clone Stamp Tool to paint over a 
small area of pipe, making sure that 
the lines of the siding stay lined up. 

Here, I’m using the Clone Stamp Tool to sever the 
vertical stretch of pipe from the part of the pipe 
that intersects with the ledge of the building. This 
will make the vertical part easier to remove.
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Attempt 1: The Healing Brush  
Now I have severed the stretch 
of pipe. My next inclination 
would be to remove the stretch 
of pipe using the Healing Brush. 
When using the Healing Brush, 
it started off aligning things 
properly, but the more I paint-
ed, the more “off” the align-
ment got. Because this first 
“go-to” technique didn’t work, 
I had to try something else.  

Attempt 2: Distort transform 
I then tried to use the distort 
command in order to shape the 
layer into alignment. I used the 
Lasso Tool to create a selection 
of clean siding to the right of 
the pipe I want to remove and 
then I copied that selection to 
its own layer by going to the 
Edit menu and choosing Copy 
Merged. (I use this command 
any time I am doing retouch 
work because the content may 

At left, you 
can see the 
result of my 
first attempt 
at using the 
Healing Brush 
to remove the 
pipe. It started 
out looking 
nice at the 
bottom, but it 
became out of 
alignment at 
the top. 

I used the 
Lasso Tool to 
make a se-
lection of an 
area next to 
the pipe. 
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be made up of more than one layer, including the layer designed to contain retouch 
work.) I then pasted the content onto its own layer and used the Move Tool to move 
this layer to the left so that it covered up the pipe and its shadow. 

I then went to the Edit menu 
and chose Transform > Dis-
tort. The Distort command al-
lows us to adjust the four cor-
ners of the targeted content 
individually. A transform box 
appeared around the layer 
and I moved the four corners 
to try and line up the lines of 
the siding. When doing this, 
you will need to hold down 
the Shift key while moving the 
handles so that Photoshop 
does not try and scale things 
proportionally. I did my best 
to align the lines of the siding, 
but alas, this technique didn’t 
work either. 

Attempt 3: Puppet Warp When the other retouching tools don’t work in a scenario 
like this, I would then turn to the Puppet Warp feature. I will keep the layer dupli-
cate that I created and then moved to cover the piping. With this layer active, I’ll go 
to the Edit menu and choose Puppet Warp. By default, a mesh overlay will appear 
on the layer. If you don’t want to see this mesh, you can turn off the “Show Mesh” 
check box in the Options Bar. That’s what I did in the video. I also set the Density 
menu (also in the Options Bar) to More Points. This just allows the tool to be more 
precise. 

I copied the selection 
to its own layer and 
moved that layer to 
cover the pipe. Here, I 
am  using the Distort 
command to try and 
line up the layers. As 
you can see, the re-
sults are not perfect.
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Now, I will hover my cursor over one of the plac-
es where the lines in the layer duplicate aligns 
perfectly with the image in the background and I 
will click to add a point. Then I will find a location 
on the other side of the layer where it perfectly 
aligns with the background and I will click to add 
another point. Now I have points on the left and 
right sides of the layer. These points are going to 
serve as anchors, holding the layer in place. 

Next, I will hover my cursor over an area near the 
top of the layer, where it does NOT align with the 
underlying image. This time, I will click and drag. 
When you click and drag using Puppet Warp, you 
will add a point and move it up or down in order 
to align the content with the underlying layer. I will 
continue clicking and dragging to add points, po-
sitioning them so they line up with the underlying 
building. You can add as many points as you want 
here, but be careful about placing them too close 
to each other as this can result in less-than-opti-
mal results. 

The Puppet Warp feature is active and there are some settings I changed in the Options Bar. 
At left, you can see that I turned off the “Show Mesh” check box. At right, I set the Density 
menu to More Points which gives the tool more precision.

Using Puppet Warp, I clicked to 
place two points in spots where 
the active layer aligned nicely with 
the underlying layer.

I clicked to add more points and 
dragged the content into align-
ment with the underlying layer.
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Healing Brush Trick

I was able to successfully remove the pipe using the Puppet Warp feature, but I had 
originally wanted to use the Healing Brush, because the Healing Brush will match 
the color and brightness to the surrounding area. Let’s look at a trick that might 
allow me to complete the retouch job using the Healing Brush. 

I will still use the layer that I puppet-warped 
in the step above, but I will drag this layer to 
the very bottom of the layer stack. I’ll then 
turn off the visibility of all the other layers. 

With the Healing Brush active, I’ll set the 
brush so that it fits within the strip of sid-
ing I have in the layer. I’ll position the cursor 
somewhere within the layer (not overlapping 
any transparent area), hold down the Option 
key (Alt on Win) and I’ll click once in order 
to copy that area.  Then, without moving the 
cursor at all, I’ll release the Option key and 
click again. This pastes the content in the ex-
act spot we copied, but it also determines 
the sample area so that when I click again, it 
will remember where to copy from. 

Now I’ll turn on the visibility of the other lay-
ers and I will activate the first layer I created 
for applying the retouching (It should be at 
the top.). With the retouching layer active, I 
will use the Healing Brush to paint over the 
pipe in order to remove it. When I paint, it is 
using the source content from that bottom layer I sampled from and it is applying 
that content to the active layer, matching the colors and brightness to the image 
surroundings.

LEFT: I moved the layer duplicate to 
the bottom of the layer stack and am 
sampling an area of siding. RIGHT: I am 
using the Healing Brush to paint on the 
retouching layer, covering up the piping.
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Retouching out the bench

Now I will try to remove the bench that is sitting in front of the building. To do this, 
I will have to think about what kind of content would be there if the bench was 
not present. Looking at the surroundings, I can tell that it would be brick wall that 
has the sun shining on it. Now I need to look at the rest of the image and see what 
areas contain bricks in the sun, because it is these areas that I will need to use in 
order to fill in the area where the bench is. In this image, the two pillars in the front 
of the building contain bricks in the sun, so I will try to sample from one of these 
pillars. The pillars don’t contain enough bricks horizontally to fill in the area where 
the bench is, but that’s ok because I can use what is there to manually create a 
brick wall.

I will use the Polygonal Lasso Tool to make a selection of the part of the far pillar 
that is in the sunlight. This selection needs to be copied to its own layer so I’ll go 
to the Edit menu and choose Copy Merged. Then I’ll go back to the Edit menu and 
choose Paste. Again, I am using the Copy Merged command instead of using the 
keyboard shortcut for duplicating a layer. This is because whenever I am doing re-

I had to evaluate the image to determine what content I would use to cover up the bench. It 
needs to contain bricks in the sun, so I decided to use the pillar (circled). 
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touch work, the content I want to copy may be contained on more than one layer 
and I just get into the habit of using the Copy Merged command so that I know I 
am copying the contents of the selection, along with any retouching applied to it. 

I’ll move the new layer of bricks over to the bench area and position the left edge 
so that it lines up with the edge of the building. Now I need to duplicate this layer 
a few times in order to create a large enough wall to cover the bench. To quickly 
duplicate a layer, you can hold down the Option key (Alt on Win) while clicking and 
dragging on the layer. By holding the Option key down, you will be dragging over 
a duplicate of the layer instead of the layer itself. That is what I will do in order to 
duplicate the bricks layer. I will use the Move Tool to try and position the layer du-
plicate so that it lines up with the bricks from the other layer. I can’t get the bricks 
to perfectly align so I will use the Puppet Warp feature like I used to remove the 

FAR LEFT: I used the 
Polygonal Lasso Tool 
to make a selection 
around the sunny 
bricks. 

DIRECTLY LEFT: I 
copied the selection 
to its own layer and 
am positioning that 
layer to line up with 
the left edge of the 
building. 
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piping earlier in the lesson. I’ll go to the Edit menu and choose Puppet Warp, then 
click to position a pin or two in the areas where the layers do line up. I’ll then click 
on an area that doesn’t line up and drag to position the content so the lines of the 
bricks align correctly. I’ll hit Enter/Return to exit the Puppet Warp feature. I can 
still see some hard lines that show where the two layers meet, so I will activate the 
Eraser Tool and paint with a small, soft brush over some of the brick faces, soften-
ing the transition from one layer to another. 

LEFT: I duplicated the bricks layer and am align-
ing the two layers using the Puppet Warp feature. 
ABOVE: I could still see a seam between the two 
layers so I am using the Eraser Tool, set to a small, 
soft brush, and am painting over some of the brick 
faces in order to soften the transition.



Aligned Retouching © Ben Willmore, All rights reserved 11

I’ll now repeat the process of duplicating the brick layer, using Puppet Warp to 
align the duplicate to the underlying brick layer and then using the Eraser Tool to 
create a soft transition. Once I have done this a few times, I can start to duplicate 
more than one layer at a time to make the process go by faster. Once I have enough 
layers to cover the area where the bench is, I’ll select all of the brick layers and then 
go to the Edit menu and choose Merge Layers. (You could also put the layers into 
a Group if you didn’t want to merge them.) 

Now that I have a large layer of bricks, I’ll use the Move Tool to position them over 
the bench area. The first thing I notice is that the angle if the bricks is not correct. 

I positioned the merged brick layer over the bench and you can see that the angle of the 
bricks is not correct. I will need to adjust this in order to make it look natural. 
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I will hide the bricks layer and then make a selection of the area I want to fill with 
the bricks. With the selection active, I’ll turn the visibility of the bricks layer back 
on and add a layer mask by clicking on the Layer Mask icon at the bottom of the 
Layers panel. This will hide the brick layer everywhere outside of the selection. 

Now I want to warp the bricks so that they are at the appropriate angle. Before us-
ing the Transform command, however, I need to unlink the layer contents from the 
layer mask. If I don’t do this, then the bricks will move ALONG with the layer mask. 
I want the bricks to move while the layer mask stays in place. To do this, I will click 
on the little link icon that appears between the layer icon and the mask icon in the 
Layers panel. Then, I’ll click on the layer thumbnail in order to make it active. You 
can tell which one is active because it will have white brackets around it. 

I made a selection around the area that I would like to fill with a brick wall. 

LEFT: The link icon indicates that the bricks layer is linked to its layer mask. RIGHT: I clicked 
on the link icon to unlink the layer from the mask. I also clicked on the layer thumbnail to 
make it active. You can tell which is active because there will be white brackets surrounding 
the thumbnail. 
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With the bricks active, I’ll click on the Edit menu and choose Transform > Distort. 
Now I can drag the transform handles to position the bricks at the correct angle. 
Note that when doing this, you will need to hold down the Shift key in order to 
move the four corners independently of one another. When the bricks appear to 
be in the correct angle, I’ll hit the Return/Enter key to lock in the transformation.

Now, there should be a shadow along the top of the bricks, just beneath the con-
crete ledge. I will create a new, empty layer and activate the Brush Tool. I’ll use a 
semi-soft brush and then sample a shadow area within the image in order to choose 
the right color. To sample a color while the Brush Tool is active, I’ll hold down the 
Option key (Alt on Win) and the cursor will temporarily turn into an eyedropper. I’ll 
use the eyedropper to click on the color I want to sample and then release the Op-
tion key to get back to the Brush Tool. I will use the Brush Tool to paint a line along 
the top of the bricks and then change the blending mode of the layer to Multiply. 
(The Blending Mode menu is located at the top of the Layers panel.) 

At left, the Distort 
command is being 
used to position the 
brick layer so that it 
lines up with the un-
derlying layer. 
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The brush stroke covered part of the concrete and some of the gas pump, so I will 
need to mask the layer so that it appears only on the bricks. Because the shadow 
layer is positioned directly above the brick layer, I can use a clipping mask. A clip-
ping mask will make the current layer only show up where there is content in the 
layer below. With the shadow layer active, I’ll go to the Layer menu and choose 
“Create Clipping Mask.” Now the shadow only appears over the bricks, which is 
where it should appear. 

I am working on an 
empty layer and 
painting a line of 
dark color (that 
was sampled from 
the shadow area 
in the image) over 
the bricks. This will 
simulate the shadow 
that is created by 
the concrete ledge. 


